Учебник FTP: краткий список команд

Команды

Ниже приведен краткий перечень команд, необходимых для того, чтобы переписать требуемый файл или файлы при использовании FTP-клиента с командной строкой. Если есть желание узнать остальные команды, которые нужны для профессиональной работы с FTP, то введите help в Вашем FTP-клиенте.
При работе с графическим клиентом, поддерживающим современный интерфейс, Вам, скорее всего, все будет понятно без объяснений.
Учтите, что в именах файлов большие и маленькие буквы различаются.

open имя_сервера - открыть соединение
- открывает соединение с сервером. Это имя можно указать сразу при вводе команды, загружающей клиента: ftp ftp.karelia.ru.
cd имя_директории - сменить каталог
- осуществляет переход в другой рабочий каталог на FTP-сервере.
dir [имя_файла] - выдать список файлов
- выдает список файлов в текущей директории. Если Вам интересен формат списка каталога, нажмите здесь. Не забывайте, что можно использовать шаблоны групповых операций.
get имя_файла [имя_локального_файла] - переписать файл
- переписывает файл с удаленного компьютера на локальный. Если указано имя локального файла, то записывает его под этим именем, иначе - в каталог по умолчанию.
mget [имя_файла] - переписать группу файлов
- то же самое, что и get, но разрешается использовать шаблоны. Перед копированием каждого файла будет запрашиваться подтверждение. Для отмены подтверждений введите prompt.
prompt
- отменяет подтверждение в командах mget и mput.
put имя_файла [имя_удаленного_файла] - записать файл на сервер
-переписывает файл с локального компьютера на удаленный под именем имя_удаленного_файла. Если оно не указано, то файл записывается в текущий каталог с именем локального файла. Команда запрещена для анонимных пользователей
mput [имя_файла] - записать группу файлов
- то же самое, что и put, но разрешается использовать шаблоны. Перед записью каждого файла будет запрашиваться подтверждение. Для отмены подтверждений введите prompt.
ascii
- устанавливает ascii-способ передачи файлов. Используется для пересылки файлов-текстов на английском языке. Однако для надежности лучше использовать binary.
binary
- устанавливает двоичный способ пересылки файлов. При этом файл при передаче не перекодируется и записывается в неизмененном виде. Это наиболее надежный способ передачи файлов.
close
- закрывает соединение с данным сервером и производит возврат в командный режим. Эта команда автоматически выполняется при выходе из FTP-клиента.
quit
- выход из FTP-клиента.
user
- регистрирует на текущем сервере с новым именем. Используйте эту команду, если Вы первый раз по ошибке неправильно ввели имя анонимного пользователя и не хотите снова перенабирать команду open.
lcd [имя_директории]
- осуществляет переход на локальном компьютере в указанный каталог.
pwd
- выводит на экран текущий каталог на удаленном компьютере.
system
- выводит на экран тип операционной системы на удаленном компьютере.

help [FTP-команда] - помощь
- выдает краткую информацию о командах FTP-клиента или о конкретной указанной команде.


Учебник FTP: навигация по каталогам

Каталоги

Для того, чтобы ориентироваться в море программ, доступных в Internet, необходимо иметь представление о расположении файлов на компьютере. Скорее всего, Вы уже знаете, что файлы распределены по каталогам, которые также называются директориями или папками.
В определенный момент пользователь находится только в одном каталоге, который называется текущим. По команде get имя_файла, компьютер ищет файл в текущем каталоге. Для навигации по серверу Вам надо знать имя текущего каталога и способы передвижения по ним.

Так как традиционной операционной системой для многопользовательских систем является UNIX, то везде Вам придется использовать имена каталогов в стиле UNIX.

Общий вид пути в файлу выглядит так:
/имя_каталога/имя_подкаталога/имя_файла
где имя_подкаталога может повторяться сколь угодно раз или его может не быть вовсе. Наверное, Вы уже заметили, что имена каталогов разделяются знаком '/'. Пользователям MS DOS придется привыкнуть: используется не обратный слэш('\'), а прямой.
Слэш в самом начале пути означает, что отсчет начинается с самого верхнего - root каталога. Если слэша в начале нет, то компьютер интерпретирует путь, начиная от текущего каталога, как бы склеивая имя текущего каталога с указанным.
Например:
Текущий каталог: /pub/3d
Вы указываете каталог: programming/cpp
Результат: /pub/3d/programming/cpp

Такой сокращенной записью пути (начиная от текущего каталога) пользуются очень часто. Конечно удобнее указать каталог, который находится в текущем каталоге, чем писать весь путь.

Переход между каталогами производится с помощью команды cd- Change Directory. Ее синтаксис:
cd имя_директории
Наиболее часто применяемый способ навигации в каталогах - узнать список файлов и каталогов в текущем каталоге командой dir и перейти в требуемый подкаталог командой cd, не думая ни о каких правилах составления путей при помощи слэшей.

На этапе исследования сервера Вы, очевидно, будете заходить во все каталоги и просматривать их содержимое. Поэтому удобно знать команду перехода в предыдущий каталог.
cd ..
'..' - это псевдоним родительского каталога. Вы можете использовать его в формировании путей.
cd ../newsoft переход в newsoft, который находится в родительском каталоге.
Учтите, что маленькие и большие буквы различаются.

Вот графическое изображение структуры каталогов:

Рисунок иерархии каталогов

Хотя в Internet все еще встречаются системы, которые посылают списки файлов в своем формате (например: MSDOS, Mac OS), однако не стоит беспокоиться: форматы вполне понятны, а команды везде одни и те же. Операционную систему удаленного компьютера можно узнать, введя system. Как Вы думаете, какая операционная система установлена на FTP-сервере фирмы Microsoft?

Список файлов в текущем каталоге можно узнать с помощью команды dir. На первый взгляд в списке мало понятного. Но будем двигаться слева направо.
Сначала идут 10 символов. Это биты доступа. Для Вас представляет интерес только первый символ. Если это '-', то он обозначает файл, если 'd' - то директорию.
Следующие два столбика - имя владельца и имя группы, это относится к системе защиты UNIX и для пользователя FTP не представляет интереса.
Затем идет число - размер файла. Самый правый столбик - имя файла или директории.


Учебник FTP: формирование адресов в Internet

Формирование адреса

Для того, чтобы обратиться к удаленному компьютеру в Internet, нужно иметь его адрес. Знать правила формирования адресов не обязательно, но полезно. Представляя особенности их формирования, можно определить физическое расположение сервера (хотя далеко и не всегда), организацию-владельца, ее область деятельности

Итак, адрес в Internet состоит из набора доменов, причем уточнение идет справа налево. Имена доменов разделяются точкой. Вложенных доменов может быть сколь угодно много.
Существует негласное правило, согласно которому крайний правый домен определяет или страну, или принадлежность владельца к какой-либо области деятельности.
Первоначальные "организационные" домены:

  • edu - образование
  • gov - правительственное учреждение
  • mil - военная организация
  • com - коммерческая организация
  • org - некоммерческая организация
  • net - другие сети

    •

    Первоначальные "географические" домены:

  • ru (su) - Россия
  • fi -Финляндия
  • se -Швеция
  • uk - Великобритания
  • lv -Латвия
  • ua - Украина
    Каждая страна имеет свое имя.
    •

    Например: mainpgu.karelia.ru
    Домен ru в конце обозначает Россию (RUssia).
    Далее указан домен 'karelia', также являющийся "географическим". Деление регионов на географические зоны произвольно. Обычно это делается с учетом количества населения. Если город большой, например, Москва или Санкт-Петербург, то его имя может следовать сразу за 'ru'. Адреса в Москве имеют вид: домен.msk.ru или домен.msk.su. Адреса, оканчивающиеся на su были созданы еще при Советском Союзе, а затем их менять не стали, так как часть пользователей работают со старыми адресами.

    Самым левым доменом в адресе обычно является имя конкретного компьютера. Имя компьютера условно. За одним именем могут стоять сколь угодно много компьютеров, распределяющих информацию по своим правилам.

    Если требуется указать имя пользователя, то справа приписывается его имя и знак '@'.
    Например:skyer@mainpgu.karelia.ru - обозначает пользователя с именем skyer на компьютере mainpgu.karelia.ru.

    Зачастую FTP серверы имеют в начале адреса домен ftp, но это не является обязательным и используется не всегда.


Учебник FTP: общее описание действий

Для того, чтобы скопировать файл

с FTP сервера нужно:

  1. открыть соединение с этим сервером
  2. зарегистрироваться
  3. установить требуемый тип пересылки
  4. перейти в нужный каталог
  5. указать файл для передачи на локальный компьютер.

Для реализации этих шагов:

  • войдите в программу-клиент FTP;
  • дайте команду open имя_сервера;
  • введите имя анонимного пользователя anonymous после приглашения login :;
  • введите Ваше имя и адрес локальной машины в качестве пароля: password: мое_имя@имя_моего_домена;
  • установите двоичный тип пересылки файла: binary;
  • войдите в требуемую директорию одной или несколькими командами cd имя_директории;
  • дайте команду get имя_файла


Учебник FTP: ftp-mail

FTP-mail

Многие протоколы в Internet подразумевают прямое подключение. Однако не все пользователи имеют такую возможность. Гораздо проще подключаться на незначительное время и быстро одним пакетом переписывать всю информацию. Такие возможности предоставляет электронная почта (e-mail). Кроме того, почта не требует немедленной обработки. Лежит себе письмо в почтовом ящике, никому не мешая, до тех пор, пока не появится свободное время у получателя, чтобы посмотреть его. Почтой обычно занимаются специально выделенные для этого компьютеры, работающие в автоматическом режиме.

Все описанное выше повод для пересылки файлов по почте. Действительно, заказали Вы себе файл и получили его через несколько дней, не заботясь ни о каких разрывах связи, не нервничая перед дисплеем, глядя на медленно увеличивающиеся проценты. Поэтому были созданы специальные службы, которым можно заказать требуемый файл по почте. Это и называется FTP-mail.

Запоминать специальных команд для заказов не требуется. Просто Вы указываете в письме обычные FTP-команды в порядке их следования. Письмо может выглядеть примерно так:

To:      ftpmail@имя_специального_сервера
Subject:

open ftp.karelia.ru
cd pub
dir
close

- для того, чтобы Вам прислали список файлов из /pub. Чтобы заказать файл:

To:      ftpmail@имя_специального_сервера
Subject:

open ftp.karelia.ru
cd /pub/msdos
get kermit.zip
close

Сервис ftp-mail является удобным средством для получения больших файлов. Кроме того, есть возможность предварительной обработки файлов, например, разбить их на куски по 64k до пересылки их Вам (удобно для модемов). Однако имейте в виду, что кто-то (скорее всего Вы) оплачивает почту, так что выясните это прежде чем пользоваться услугами ftp-mail.


Работа с FTP в среде WWW

Как показывает практика, на сегодняшний день основной услугой Internet является WWW. Весь мир с замиранием сердца следит за сражениями броузеров, Java, технологий встраивания multimedia в HTML-страницы. Однако любому человеку понятно - главное, это уметь использовать уже существующие инструменты. Основой данной главы будет рассмотрение части возможностей http протокола, а именно - передачи файлов. Каждый, кто работает с WWW знает, что такое URL, Uniform Resource Locator. На сегодня это основной способ указания ресурсов Internet. Наиболее подробно об URL можно прочесть в RFC 1738 и RFC 1808. Общий формат URL: &ltscheme>:&ltscheme-specific-part>. Например, для HTML файла можно сформировать следующие URL:
http://www.karelia.ru.
Для почтовога адреса: mailto:skyer@mainpgu.karelia.ru.

FTP также является ресурсом Internet. URL для ftp выглядит так: ftp://&ltuser>:&ltpassword>@&lthost>:&ltport>/&lturl-path>, где user - имя пользователя, password - его пароль, host - доменное имя или IP адрес сервера, url-path - путь к файлу. На практике наиболее часто используемым вариантом ftp является анонимный. Как уже было сказано выше, анонимный ftp ничем не отличается от "остального". Просто в качестве имени пользователя достаточно указать anonymous, а в качестве своего пароля - свой почтовый адрес. Для анонимного ftp в url сделан упрощенный синтаксис: ftp://&lthost>/&lturl-path>, то есть при отсутствии имени автоматически будет вставлено anonymous. Порт также обычно не указывается, а используется стандартный 21.

Примеры адресов ftp в форме url:
ftp://ftp.cdrom.com/pub/music/songs/1996
ftp://ds.internic.net/rfc/rfc1738.txt
В качестве host можно указывать и IP адрес. (118.24.64.24)

Основное применение url нашли в WWW броузерах. На сегодня это, наверное, самые популярные программы в Internet. Netscape Navigator, Internet Explorer, Mosaic, Lynx, Arena. Поэтому если Вы используете их, имеет смысл использовать их и как ftp клиент. Правила формирования адреса были описаны выше, все остальное предельно просто. Если в качестве пути указан только путь к некоторому каталогу, а не сам файл (пример 1), то броузер покажет Вам список файлов в этом каталоге. Если же путь указан вплоть до имени файла, то вскоре файл с некоторой вероятностью окажется у Вас на диске. Почему с некоторой вероятностью? Потому, что к сожалению, http использует для ftp собственную подсистему пересылки файлов. Что не привело к повышению надежности. Однако об этом чуть позже.

Искушенный пользователь WWW заметит, что иногда адреса файлов в url в качестве scheme содержат http вместо ftp. Это разные, и в то же время одинаковые вещи. Дело в том, что указывая http, Вы говорите WWW серверу искать файл в области каталогов, которые отведены HTML файлам. Если ftp, то указываемые каталоги будут совпадать с теми, которые доступны посредством классического ftp.

Сравнение HTTP и FTP путей
URL | Реально на сервере
ftp://ftp.karelia.ru/pub/unix | /home/ftp/pub/unix
http://ftp.karelia.ru/pub/unix | /files/www/pub/unix

Хотя реально принципы передачи в обеих случаях одинаковы. На самом деле здесь кроется одна очень большая проблема. Некоторые организации, имеющие быстрый доступ к Internet забывают, что не у всех он столь же быстр. Таким пользователям удобно использовать классический ftp вместо WWW броузера. Дело в том, что реализация ftp в http оставляет желать много лучшего.

Основной предмет критики - отсутствие такой полезной функции как reget. Это особенно актуально для низкоскоростных российских коммуникаций, где скорость порой падает до нескольких десятков байт в секунду. При такой скорости разрыв соединения - очень частое явление. И переслать файл в несколько мегабайт уже является большой проблемой. При потере соединения Вы воспользуетесь reget в ftp клиенте, однако в среде WWW Вам, увы, придется начать все сначала. Более того, если Вы работаете с WWW через proxy, основанном на программном обеспечении от CERN, то есть вероятность, что при обрыве соединения он решит, что весь файл уже переслан и на все попытки получить его с удаленного WWW сервера proxy будет выдавать урезанный файл со своего диска. В таком случае два совета - либо смените proxy сервер, либо вообще отключите его использование.

Однако имейте в виду, что на сегодня очень популярны так называемые firewall, когда реальный выход в Internet имеют только proxy и последний совет в таком случае бесполезен. Есть еще третий совет - подождите несколько дней, пока proxy не позабудет про Ваш файл и снова обратится в Internet для его пересылки. Однако это, безусловно, не рабочее решение.

Иногда http и ftp каталоги синхронизированы. Хорошим представителем является ftp.cdrom.com. Там каталоги не только синхронизированы, но и очень красиво оформлены при обращении к ним из WWW-броузера. Делается это просто, но не каждый соберется так красиво все оформить.

Кроме всего сказанного, оставшихся оптимистов ожидает еще одна пилюля. Согласно протоколу http, через который осуществляются коммуникации WWW, после каждого сеанса связи соединение между компьютерами разрывается. Это означает, что если Вы решите с удовольствие погулять в броузере по каталогам, то возможно это не всегда будет так здорово, как кажется. На установление соединения, регистрацию пользователя уходит несоизмеримо больше времени, чем интерактивная работа в ftp клиенте. Вот так вот приходится платить за современный модный интерфейс.

Некоторые выводы:

  • Преимущества:
    • Высокая интеграция в гипертекстовое пространство Internet.
    • Современное программное обеспечение.
  • Недостатки:
    • Отсутствие reget.
    • Невысокая надежность соединения на плохих линиях.
    • Встречающиеся проблемы при обрыве соединения со включенным proxy
    • Невысокая скорость работы из-за закрытия соединения после пересылки.
    • Недоступность файлов через ftp, адресуемых через протокол http (хотя это и не недостаток самого http, это его особенность.)

Как нетрудно заметить, все недостатки компенсируются надежными и быстрыми линиями связи. Уже достаточно канала в 256k у провайдера, и основные проблемы исчезают.

Необходимо отметить, что в ближайшем времени http станет основной системой для пересылки файлов. Большую роль здесь играет развитие WWW, на которую теперь ориентируются практически все системы в Internet. Плюс постоянный рост возможностей самих броузеров. Сегодня уже часто оказывается удобнее воспользоваться ftp-mail. А Netscape Navigator уж сам извлечет файл из письма, распакует его и приготовит для запуска. Таким образом, служба ftp сегодня сильно меняется. Сам ftp всегда являлся достаточно актуальной проблемой, что очень хорошо видно при просмотре документации. Публикации на эту тему появлялись в Internet регулярно с 1973 года, хотя тогда это еще и не называлось Internet.

Кроме того, актуальность просто пересылки файлов для рядового пользователя падает. Если раньше большое количество документации, звуков, изображений лежало мертвым грузом на ftp, то теперь все чаще ту же информацию можно получить в виде красиво оформленного, и с большей вероятностью более свежего, html файла. Однако предсказать дату, когда получение информации не будет выражаться в виде конкретного файла пока невозможно. И большинство людей так и работает "по старинке". Все-таки архивы программ ПОКА еще остаются файловыми архивами.


Учебник по FTP: Глоссарий терминов

Список терминов

FTP - File Transfer Protocol
- это протокол передачи данных. Он предназначен для передачи файлов с удаленного компьютера на локальный.
FTP-server
- это понятие, за которым скрывается обычный компьютер. Но так как он содержит общедоступные файлы и настроен на поддержку протокола FTP, то его называют сервером - поставщиком информации. Вообще, практически любой компьютер с операционной системой UNIX позволяет подключаться к нему по FTP протоколу. Соединение выполняется с помощью FTP клиента
FTP соединение
- это значит, что Вы соединились с удаленным компьютером при помощи FTP протокола
FTP-client
- это сервисная программа, с помощью которой можно произвести соединение с FTP сервером. Обычно эта программа имеет командную строку, но некоторые имеют оконный интерфейс и не требуют запоминания команд.
anonymous
- это имя анонимного пользователя. Анонимность пользователя заключается в том, что он имеет право только копировать (download) общедоступные файлы и не может записывать на сервер новые (upload).
upload
Таким словом обозначается процесс записи файлов с локального компьютера на удаленный. Это процесс обратный download.
download
Таким словом обозначается процесс записи файла с удаленного компьютера на локальный. Это процесс, обратный upload.
login
Каждый пользователь в системе должен иметь свое имя. Поэтому существует такая операция login, с помощью которой входящий пользователь регистрируется. Эта операция применяется не только в FTP, но м в других системах, например telnet. В принципе, для обычного пользователя все это заключается в простом правиле - после того, как на экране появится слово login:, нужно ввести имя для входа в систему. Например:
login: anonymous
password
Для обеспечения безопасности компьютерных систем одного имени для входа в систему недостаточно. Ведь можно запросто узнать имя владельца системы и воспользоваться им. Но эта проблема легко решается с помощью пароля. После того, как Вы ввели имя, требуется ввести пароль, который известен только Вам или определенному кругу лиц. В системе FTP для анонимного пользователя паролем служит Ваш адрес на локальном компьютере в формате e-mail адреса Internet'а. Если Вы его не знаете, справьтесь у своего администратора. Вообще его общий вид: имя@домен.домен где домен - это имя домена.
Когда будете набирать пароль, не удивляйтесь, что буквы не появляются на экране - это в целях безопасности.
В принципе, для анонимного пользователя пароль вроде бы как и не нужен, но он все-таки введен для того, что бы быть уверенным, что человек осознает, что он делает.
И еще: многие FTP клиенты вводят пароль анонимного пользователя автоматически, если Вы нажмете Enter после приглашения. Проверьте это на своей программе.
telnet
Иногда требуется подключиться к удаленному компьютеру так, чтобы работать как бы с клавиатуры этого компьютера. Это можно осуществить, используя telnet. Однако копирование файлов на локальный компьютер при таком подключении затруднено, но возможно при помощи таких протоколов как, например, ZMODEM, KERMIT, которые обычно применяются в модемах. Встретить такие протоколы можно на Internet BBS. Однако не стоит сильно рассчитывать на такой способ копирования файлов.
WWW
- World Wide Web. Система гипертекстовых документов, ныне являющаяся, наверное, самой популярной системой на базе Internet'а.
HTTP - HyperText Transfer Protocol
Этот протокол используется в системе WWW. Имеет в своем составе несколько других, например предмет рассмотрения данного учебника - FTP.
root-каталог
- самый верхний каталог в иерархии файлов. Обычно, когда Вы открываете FTP соединение, то находитесь в root-каталоге. Но некоторые "умные" программы могут автоматически перейти в каталог, который Вы укажете при запуске или в тот, в котором Вы побывали в последний раз на этом сервере. Перейти в root-каталог можно командой cd /
UNIX
- одна из популярнейших многотерминальных операционных систем. Она обеспечивает достаточную надежность и безопасность, позволяя работать одновременно нескольким пользователям, распределяя между ними ресурсы вычислительной системы.
Archie
- база данных по содержимому FTP серверов. Их в мире несколько. Раз в месяц они 'обзванивают' все известные им FTP сервера и обновляют свою базу данных. Рекомендуется использовать ближайший archie сервер для равномерного распределения запросов по всему миру. Самый близкий к России archie.funet.fi Для того, чтобы воспользоваться этой базой данных Вам потребуется telnet-соединение. Наберите имя пользователя archie и затем prog имя_файла. Вас поставят в очередь и сообщат расчетное время поиска. По прошествии этого времени Вам будут сообщены все ссылки на файлы, в именах которых встретилось указанное Вами слово.
Remote computer
- удаленный компьютер. Это компьютер, с которым мы инициируем соединение. Удаленный - это не значит, что он находиться далеко. Он может находиться и на соседнем столе.
Local computer
- локальный компьютер. Это компьютер, с которого мы в данный момент работаем и совершаем соединение.
FTP-командны
- последовательность команд, удовлетворяющих синтаксису FTP.
FTP-mail
- служба доставки файлов с FTP-серверов по электронной почте.


А. Стояновский, Учебник FTP

УЧЕБНИК FTP

Мы не откроем ничего нового, утверждая, что Internet - это всемирная сеть, заключающая в себе ОГРОМНЫЕ информационные ресурсы. Для человека информативными являются звуки, изображения, ощущения, запахи и так далее, компьютеры же привычные человеку образы могут получать, хранить и передавать только в виде последовательности байтов (файлов). И если обмен информацией между компьютерами на самом деле - это обмен файлами, то для человека получить по сети какой-либо образ - значит скопировать на свой компьютер соответствующий файл. Тем, кто хочет использовать Internet как можно продуктивнее, необходимо уметь искать и копировать нужные файлы.

В Internet есть много способов передачи информации c удаленного компьютера на локальный. Цель данного документа - ознакомить и научить одному из них, использующему FTP - File Transfer Protocol. Этот протокол делает доступным большую часть программного фонда Internet.
Главное назначение FTP - это пересылать (копировать, передавать) файлы. FTP можно использовать самостоятельно, а также через другие системы, например, WWW имеет FTP как часть своего протокола.

FTP серверы разбросаны по всему миру, но для соединения с ними не требуется знания их физического расположения. В Internet к компьютеру обращаются по адресу. Например, FTP сервер фирмы Borland имеет адрес ftp.borland.com
Итак, предположим, что Вам известен адрес нужного FTP сервера . Теперь неплохо было бы соединиться с ним. Это делается с помощью специальной программы, которая называется FTP клиент. Раньше, когда выход в Internet имели только UNIX-компьютеры, все FTP клиенты были одинаковы: командная строчка со стандартным набором команд и все. Сейчас же, во времена оконных систем, появилось много программ, при использовании которых не требуется запоминать синтаксис команд, а файлы просто-напросто перетаскиваются мышкой. Однако и в их основе лежит стандартная система команд FTP. На каждое действие мышью FTP клиент генерирует последовательность FTP-команд.
В данном документе описан набор основных команд FTP, а также предложены правила работы в FTP. Несмотря на то, что материал дается на примере работы текстового FTP клиента с командной строчкой, мы постарались, чтобы советы были универсальными.

СОДЕРЖАНИЕ

  • Переписываем файлы
  • Шаблоны групповых операций
  • Структура каталогов
  • Формирование адресов в Internet
  • Синтаксис команд FTP
  • FTP-mail - файлы по почте
  • FTP через WWW
  • Советы по использованию FTP
  • Глоссарий
  • Что, если...


Учебник FTP: Введение в копирование файлов

Переписываем файлы.

Итак, Вы загрузили FTP-клиент. Для того, чтобы начать сеанс обмена с сервером, необходимо сначала открыть соединение. Для этого существует команда open имя_сервера
Слово open можно сократить до одной буквы o. Итак, попробуем:
ftp> o ftp.borland.com
Подождите несколько секунд пока компьютеры совершат соединение.

Теперь надо зарегистрироваться. Увидев приглашение login :, наберите слово anonymous. Нажмите Enter и введите свое имя, затем символ @ (без пробелов) и адрес Вашей локальной машины. Если все сделано правильно, то появится сообщение о том, что Вы вошли в систему.

Теперь Вы можете копировать себе те файлы, доступ к которым Вам определен как анонимному пользователю. Советуем начать исследование сервера с каталога /pub, так как обычно все полезные файлы помещаются именно сюда. Сейчас же Вы находитесь в самом верхнем, так называемом root-каталоге. Для того, чтобы перейти в нужный каталог существует команда cd .
Например, в каталог pub текущего каталога можно перейти:
ftp> cd pub
Получить список файлов в текущем каталоге можно командой dir :
ftp> dir
Если в появившемся списке первым символом в строке является 'd', то в строке имя каталога, если '-' - имя файла.
Предположим, что Вы нашли файл, который хотите переписать себе. Прежде, чем сделать это, надо установить двоичный режим передачи файлов binary :
ftp> binary

Возьмите себе за правило: как только соединитесь с сервером, сразу вводить эту команду. Если этого не сделать, то файл будет перекодирован и непригоден для использования (если только это не текст на английском языке). При появлении во время копирования файла сообщения

'Opening ASCII mode to transfer file'

немедленно прервите передачу файла и запустите binary. Многие современные FTP-клиенты автоматически посылают эту команду. Выполняет ли это программа, с которой работаете Вы, придется исследовать самостоятельно.
Пересылает файл на локальный компьютер команда get:
ftp> get the_file_i_like.zip
Если Вы сразу захотите положить файл в определенное место на локальном компьютере, то укажите путь как второй аргумент команды:
ftp> get the_file_i_like.zip /usr/skyer/my_new_file.zip
По умолчанию FTP-клиент кладет файл в текущую директорию на локальном диске.

Для FTP-клиента под Windows этой директорией будет каталог Windows. Для UNIX систем это будет тот каталог, откуда Вы запустили клиента. ( Не забудьте перед загрузкой клиента проверить, достаточно ли у Вас прав для записи в этот каталог. В противном случае Вам придется явно указывать путь в каждой команде get ).
Можно переписать содержимое сразу всего каталога, для этого надо указать его имя в команде get.
Зачастую требуемая информация расположена не в одном, а в нескольких файлах.

Для их пересылки можно использовать команду mget, которая понимает шаблоны групповых операций.В некоторых реализациях FTP-клиентов шаблоны групповых операций можно использовать и в команде get .

Теперь, когда файл копируется, можно отдохнуть. Время ожидания зависит от размера файла и возможностей Вашего подключения к Internet. Узнайте это заранее. Если скорость подключения около 300 байт в секунду, а размер файла - десятки мегабайт, то... Вам лучше поискать другой способ достать этот файл.
Когда пересылка файлов будет закончена, FTP-клиент сообщит Вам об этом. Теперь можно выходить из FTP-клиента (при выходе он автоматически закроет соединение с сервером) и пользоваться этими файлами, так сказать, в домашних условиях.


Учебник FTP: Советы по использованию

Советы по использованию FTP

FTP заключает в себе очень большой объем информации. Поэтому очень несложно просто захлебнуться в ней. А если еще учесть и безликость имен файлов, то приходится сделать вывод - для того, чтобы профессионально использовать FTP надо обдумывать все свои действия. Поэтому позвольте представить Вам несколько советов, дабы облегчить Ваши странствования.

  • Никогда не исследуйте FTP-пространство, соединяясь со всеми попавшимися серверами и заходя во все каталоги. Частенько новичок, получив доступ к FTP просто тратит много времени впустую, листая каждый каталог и заходя во все каталоги. Уясните сразу - нужной информации таким образом не найдете, а времени потеряете много.

    Особенно если в Ваших поисках не будет четкой цели. Дело в том, что имена файлов - это не документация к ним. Иногда встречается такое название, что его на клавиатуре то набрать сложно. А понять смысл и вовсе невозможно. Нужно также отметить, что в Internet очень много серверов, содержащих, мягко говоря, кучу хлама. А есть и всемирно известные, такие как ftp.funet.fi или ftp.cdrom.com. Не тратьте свою жизнь на изучение 'сереньких' серверов. Лучше потратьте пару дней и изучите популярные.

  • Из первого пункта Вы должны понять, что FTP-пространство - это огромный склад архивов. Поэтому нужен каталог всех документов. На первый взгляд такое невозможно - ведь это миллионы компьютеров. Однако кое у кого нашлась пара лишних долларов и на свет появилась archie - база данных по содержимому FTP серверов. С периодичностью раз в месяц эти компьютеры 'обзванивают' все известные им FTP серверы, заходят в каждый каталог и запоминают его содержимое. То есть делают работу, которую Вам пришлось бы делать вручную. К сожалению эти базы данных доступны через telnet - это протокол, по которому можно стать полноценным пользователем удаленного компьютера.

    Если у Вас есть доступ к telnet , то откройте соединение с финским archie-сервером (open archie.funet.fi) и на приглашение login: введите archie. После того, как появится командная строчка наберите prog имя_файла и затем нажмите клавишу Enter. И перед Вами списки всех серверов с указанием пути к файлам, в которых встретилось указанное имя файла. Для того, чтобы рассказать поподробнее об archie, нужен еще один учебник, в выходе которого я пока не ручаюсь.

  • Однако, как было указано в первом пункте, имя файла не всегда отражает суть его содержания. Чаще бывает даже наоборот - суть не отражает имя файла. Попробуйте сформулировать возможные имена файлов программ баз данным по электронике. Никак. Вообще, универсального решения тут дать нельзя. Но можно воспользоваться следующей особенностью. Большое количество FTP-серверов заставляет некоторых их владельцев проводить нечто вроде рекламы. Частенько можно встретить файлы примерно следующего названия: "Новые файлы на файловом сервере ...". Обычно их можно найти в телеконференциях. Вам повезло, если Вы нашли сервер по интересующей Вас тематике, который к тому же постоянно рассылает дайджесты с описанием новых файлов.
  • Если Вам все же надо быстро 'просканировать' содержимое сервера, то и тут часто не требуется заглядывание во все каталоги. Большинство серверов регулярно автоматически генерируют каталог своего содержимого и кладут его в самый верхний каталог. Вы можете переписать его себе и изучить его содержимое на досуге.
  • Относительно FTP-клиентов. Если у Вас имеется только FTP-клиент с командной строчкой, а есть желание иметь какую-нибудь среду поудобнее, то могу посоветовать использовать WWW-клиенты. Их обычно называют WWW броузерами (WWW browsers). Уже упоминалось, что WWW имеет как часть FTP. Поэтому их можно использовать и как FTP-клиенты. Необходимо только иметь ввиду, что необходимо вставлять 'ftp://' перед адресом.

    Например:
    ftp://ftp.karelia.ru
    Однако учтите, что WWW броузер каждый раз выполняет новое соединение, когда Вы переходите в новый каталог или берете файл, и закрывает после окончания действия. Поэтому такой способ исследования директорий потребует намного больше времени чем команды cd и dir.

  • В начале 90-х годов в Internet стала набирать популярность WWW - World Wide Web. Сейчас это огромная гипертекстовая сеть, охватывающая весь мир. А удобство представления информации ни с чем не сравнимо. Очень качественно подготовленные документы создают впечатление работы с документом как с программой. Поэтому WWW больше подходит для навигации в информационном поле. Поэтому стало правилом класть описания программных документов вместе с ссылкой на FTP-сервер, где эту программу можно найти. Это не значит, что для каждого файла, доступного через FTP можно найти описание в WWW . Описания есть в основном для известных программ.

    Однако воспользоваться WWW стоит вот почему: здесь существуют куда более качественные поисковые системы чем archie. И ищут они не по имени документа, а по всем словам из всех известных документов. Поэтому сформулируйте, какие ключевые слова могут встречаться в требуемой Вам теме и обратитесь к одному из поисковых серверов, например http://www.altavista.digital.com Есть вероятность, что Вы можете найти документ со списков FTP-серверов по требуемой Вам теме.

  • Частенько можно встретить огромные текстовые файлы. В них перечислены сотни FTP-серверов с кратким описанием их содержимого. Попробуйте воспользоваться ими, хотя это и не лучший способ найти требуемую информацию.
  • Если Вы незнакомы с сервером и имеете желание исследовать его, то не делайте этого в каталогах /bin, /usr, /etc, /dev - там находятся системные файлы, необходимые UNIX для работы. Там просто нет ничего интересного.
  • Ну а что же делать, если во время копирования большого файла связь неожиданно разорвалась? Вообще, есть три классических способа решения этой проблемы:
    1. Скопировать файл заново
    2. Использовать расширение команды get - reget. Ее синтаксис: get -r имя_файла. Дело в том, что если связь прерывается, то многие FTP-клиенты записывают на диск уже скопированную часть файла. Используя ключ -r, Вы указываете, что часть файла уже находится на диске и ее переписывать заново не надо.
    3. Использовать FTP-mail
  • Иногда встречаются очень большие файлы. И по определенным причинам Вы не можете скопировать его за один сеанс связи. В таких случаях можно порекомендовать использовать расширение команды get - reget. Но при этом Вам придется прерывать передачу файла искусственно, а затем при помощи reget продолжить копирование.


Учебник по FTP. Что, если...

Что, если...

Что, если... FTP-клиент не может соединиться с сервером.

Тут может быть несколько причин. Возможно, что сервер сейчас не работает. Причиной также может быть и плохая связь. Бывает так, что в результате поломки некоторых компьютеров в Internet часть серверов недоступна из того места, где Вы находитесь.
Еще одна вероятная причина - лимит анонимных пользователей на сервере. Не всякий компьютер может выдержать нашествия нескольких сотен пользователей. Поэтому администраторы FTP-серверов ограничивают число возможных подключений. Для мощных компьютеров это число может достигать нескольких сотен, для менее - нескольких десятков. Если такое произошло - то Вы получите сообщение о превышении числа возможных подключений. В таком случае попробуйте еще раз попозже.

Что, если... файл слишком большой и я не могу его переписать весь сразу.

В нашем учебнике есть советы, которые помогают в таких случаях. Обратитесь к советам поведения при разрывах связи и к главе о FTP-mail

Что, если... во время передачи файла я потерял связь с сервером.

Обратитесь к советам поведения при разрывах связи.

Что, если... я хочу найти нужный мне файл в Internet.

Воспользуйтесь поисковой системой archie или поисковыми серверами WWW

Что, если... я не могу зайти в нужный мне каталог на FTP-сервере.

Сначала проверьте при помощи команды dir, существует ли этот каталог. Если он все же существует и Вы уверены, что набрали его имя правильно, то остается одно - анонимным пользователям вход в этот каталог закрыт.

Что, если... сервер сам закрывает соединение со мной.

Если сервер закрывает соединение сразу при попытке соединиться с ним, то видимо он закрыт для доступа. Возможно, это временно, возможно и нет. Если же соединение закрывается спустя некоторое время, то скорее всего дело в следующем: иногда при аварийных ситуациях соединение как бы "повисает". Вы уже не работаете, а сервер пытается посылать Вам данные. Избежать таких ситуаций невозможно. Поэтому если Вы не посылаете некоторое время команды на сервер, то он сам закрывает соединение. Обычно это время равно десяти или пяти минутам. Время выполнения самих команд сюда не входит, то есть Вы можете безбоязненно запускать get для длинного файла.


Учебник FTP: Шаблоны групповых операций

Шаблоны групповых операций

При большом количестве файлов перебор их имен - утомительная задача. Порой трудно перечислить 5-6 файлов, а если их сотня?
Выход есть. Существует система шаблонов, которую лучше всего изучать на примерах. Перед этим объяснение специальных знаков:
Символ '*' обозначает любой набор символов.
Символ '?' обозначает один любой символ.

Примеры:

abc* | - все файлы, начинающиеся на abc
abc? | - все файлы, имеющие длину имени в четыре символа, начинающиеся на abc и заканчивающиеся на любой символ.
??abc? | - файлы с именем в шесть символов, 3,4,5 символы abc и остальные любые.
*abc | - все файлы, оканчивающиеся на abc
* | - все файлы
*a?*b??? | - это задание для Вас.

Учтите, что большие и маленькие буквы РаЗлИчАюТсЯ.